Christoph Hellwig <hch@xxxxxxxxxxxxx> writes: > On Mon, May 08, 2023 at 12:57:56AM +0530, Ritesh Harjani (IBM) wrote: >> This patch renames the iomap_page_create/release() functions to >> iop_alloc/free() calls. Later patches adds more functions for >> handling iop structure with iop_** naming conventions. >> Hence iop_alloc/free() makes more sense. > > I can't say I like the iop_* naming all that much, especially as we > it is very generic and we use an iomap_ prefix every else. > I can prefix iomap_ so it will then become iomap_iop_alloc()/iomap_iop_free(). All other helpers will be like... - iomap_iop_set_range_uptodate() - iomap_iop_set_range_dirty() - ... 'iomap_iop' prefix just helps distinguish all the APIs which are working over iomap_page (iop) structure. >> Note, this patch also move folio_detach_private() to happen later >> after checking for bitmap_full(). This is just another small refactor >> because in later patches we will move bitmap_** helpers to iop_** related >> helpers which will only take a folio and hence we should move >> folio_detach_private() to the end before calling kfree(iop). > > Please don't mix renames and code movements. Sure. Will take care of it in the next rev.