This is the 5th attempt at a patchset to implement hardlink handling in CIFS. The main differences from the last set are: 1) consolidated some of the patches to better help bisectability 2) redefined FILE_UNIX_INFO such that it has an embedded FILE_UNIX_BASIC_INFO struct. This change makes it easier to use cifs_unix_basic_to_fattr in the readdir codepath and eliminate cifs_unix_info_to_fattr. 3) minor cleanups and fewer false deltas between patches Aside from the unix readdir codepath changes listed above, the final result from this set is pretty close to the result of the last set. This one actually eliminates extra 100 lines or so too (mostly by changing posix readdir to use the existing to_fattr routine instead of adding a new one). Christoph, since most of the changes here are stuff we've already discussed, I went ahead and left your Reviewed-by: tag in place on the ones that you've already reviewed. Let me know if you object to any of the changes and we'll work it out. Christoph Hellwig (2): cifs: reorganize get_cifs_acl cifs: clean up set_cifs_acl interfaces Jeff Layton (8): cifs: have cifs_NTtimeToUnix take a little-endian arg cifs: make cnvrtDosUnixTm take a little-endian args and an offset cifs: rename cifs_iget to cifs_root_iget cifs: add new cifs_iget function and convert unix codepath to use it cifs: convert cifs_get_inode_info and non-posix readdir to use cifs_iget cifs: make serverino the default when mounting cifs: remove cifsInodeInfo->inUse counter cifs: remove "hardlink detection" from cifs_rename fs/cifs/cifsacl.c | 200 +++++++------ fs/cifs/cifsfs.c | 3 +- fs/cifs/cifsfs.h | 15 +- fs/cifs/cifsglob.h | 28 ++- fs/cifs/cifspdu.h | 14 +- fs/cifs/cifsproto.h | 21 +- fs/cifs/cifssmb.c | 4 +- fs/cifs/connect.c | 2 + fs/cifs/dir.c | 22 +- fs/cifs/file.c | 2 +- fs/cifs/inode.c | 802 +++++++++++++++++++++------------------------------ fs/cifs/netmisc.c | 24 +- fs/cifs/readdir.c | 517 ++++++++------------------------- 13 files changed, 635 insertions(+), 1019 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html