Christoph Hellwig <hch@xxxxxxxxxxxxx> writes: > On Tue, Apr 11, 2023 at 01:33:17PM +0100, Matthew Wilcox wrote: >> On Mon, Apr 10, 2023 at 10:27:10PM -0700, Christoph Hellwig wrote: >> > On Tue, Apr 11, 2023 at 10:51:50AM +0530, Ritesh Harjani (IBM) wrote: >> > > +/** >> > > + * __generic_file_fsync_nolock - generic fsync implementation for simple >> > > + * filesystems with no inode lock >> > >> > No reallz need for the __ prefix in the name. >> >> It kind of makes sense though. >> >> generic_file_fsync does the flush >> __generic_file_fsync doesn't do the flush >> __generic_file_fsync_nolock doesn't do the flush and doesn't lock/unlock > > Indeed. Part of it is that the naming is a bit horrible. > Maybe it should move to buffer.c and be called generic_buffer_fsync, > or generic_block_fsync which still wouldn't be perfect but match the > buffer.c naming scheme. > Eventually it anyways needs some work to see if we can kill the lock variant all together. I didn't do that in this series which is focused on ext2 conversion of iomap. So, if it's not that bad, I would like to keep both function definitions at one place so that it can be worked out later. >> >> > > +extern int __generic_file_fsync_nolock(struct file *, loff_t, loff_t, int); >> > >> > No need for the extern. And at least I personally prefer to spell out >> > the parameter names to make the prototype much more readable. >> >> Agreed, although I make an exception for the 'struct file *'. Naming that >> parameter adds no value, but a plain int is just obscene. >> >> int __generic_file_fsync_nolock(struct file *, loff_t start, loff_t end, >> bool datasync); > > While I agree that it's not needed for the file, leaving it out is a bit > silly. > Sure. Will fix it. >> (yes, the other variants don't use a bool for datasync, but they should) > > .. including the ->fsync prototype to make it work .. Sure, this work should go as a seperate series. -ritesh