Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote: > > + pages = (void *)(bv + npages); > > I think this cast should be to struct page **… not void *. Yeah. Doesn't change anything functionally, though, I think. > > + /* Free any pages that didn't get touched at all. */ > > + reclaim /= PAGE_SIZE; > > Any reason not to keep reclaim in PAGE_SIZE units to start with? Probably not, but I don't want to fiddle with that right now. I can send a follow up patch for it. David