Here's an updated version of this patch queue. Changes since v4 [*]: * I've removed "fs: Add folio_may_straddle_isize helper" as I couldn't get any feedback from Al Viro; the patch isn't essential for this patch queue. * The iomap_folio_ops operations have been renamed to ->get_folio() and ->put_folio(), and the helpers have been renamed to iomap_get_folio() and iomap_put_folio(). * Patch "xfs: Make xfs_iomap_folio_ops static" has been added at the end. The patches are split up into relatively small pieces. That may seem unnecessary, but at least it makes reviewing the patches easier. If there are no more objections, can this go into iomap-for-next? Thanks, Andreas [*] https://lore.kernel.org/linux-xfs/20221218221054.3946886-1-agruenba@xxxxxxxxxx/ Andreas Gruenbacher (9): iomap: Add iomap_put_folio helper iomap/gfs2: Unlock and put folio in page_done handler iomap: Rename page_done handler to put_folio iomap: Add iomap_get_folio helper iomap/gfs2: Get page in page_prepare handler iomap: Rename page_prepare handler to get_folio iomap/xfs: Eliminate the iomap_valid handler iomap: Rename page_ops to folio_ops xfs: Make xfs_iomap_folio_ops static fs/gfs2/bmap.c | 38 ++++++++++------ fs/iomap/buffered-io.c | 98 ++++++++++++++++++++++-------------------- fs/xfs/xfs_iomap.c | 41 ++++++++++++------ include/linux/iomap.h | 51 +++++++++------------- 4 files changed, 127 insertions(+), 101 deletions(-) -- 2.38.1