On Tue, Jun 28, 2022 at 02:38:55PM +0200, Christian Brauner wrote: > > -/* must be done on non-empty ITER_IOVEC one */ > > +static unsigned long found_ubuf_segment(unsigned long addr, > > + size_t len, > > + size_t *size, size_t *start, > > + unsigned maxpages) > > +{ > > + len += (*start = addr % PAGE_SIZE); > > Ugh, I know you just copy-pasted this but can we rewrite this to: > > *start = addr % PAGE_SIZE; > len += *start; > > I think that's easier to read. Dealt with later in the series (around the unification and cleanups of iov_iter_get_pages/iov_iter_get_pages_alloc). We could do that first, but I'd rather not mix that massage in here.