On Sat, Jun 25, 2022 at 01:01:13PM +0200, Jason A. Donenfeld wrote: > Now that all callers of ->llseek are going through vfs_llseek(), we > don't gain anything by keeping no_llseek around. Nothing compares it or > calls it. Shouldn't this and the checks for no_llseek simply be merged into patch 2? > + if ((file->f_mode & FMODE_LSEEK) && file->f_op->llseek) > + return file->f_op->llseek(file, offset, whence); > + return -ESPIPE; No function change, but in general checking for the error condition in the branch tends to be more readable. i.e.: if (!(file->f_mode & FMODE_LSEEK) || !file->f_op->llseek) return -ESPIPE; return file->f_op->llseek(file, offset, whence);