On Fri, Feb 18, 2022 at 12:25:41PM -0800, Stefan Roesch wrote: > > > On 2/18/22 12:22 PM, Matthew Wilcox wrote: > > On Fri, Feb 18, 2022 at 12:14:50PM -0800, Stefan Roesch wrote: > >> > >> > >> On 2/18/22 12:13 PM, Matthew Wilcox wrote: > >>> On Fri, Feb 18, 2022 at 12:08:27PM -0800, Stefan Roesch wrote: > >>>> > >>>> > >>>> On 2/18/22 11:59 AM, Matthew Wilcox wrote: > >>>>> On Fri, Feb 18, 2022 at 11:57:27AM -0800, Stefan Roesch wrote: > >>>>>> This adds a flags parameter to the __begin_write_begin_int() function. > >>>>>> This allows to pass flags down the stack. > >>>>> > >>>>> Still no. > >>>> > >>>> Currently block_begin_write_cache is expecting an aop_flag. Are you asking to > >>> > >>> There is no function by that name in Linus' tree. > >>> > >>>> first have a patch that replaces the existing aop_flag parameter with the gfp_t? > >>>> and then modify this patch to directly use gfp flags? > >> > >> s/block_begin_write_cache/block_write_begin/ > > > > I don't think there's any need to change the arguments to > > block_write_begin(). That's widely used and I don't think changing > > all the users is worth it. You don't seem to call it anywhere in this > > patch set. > > > > But having block_write_begin() translate the aop flags into gfp > > and fgp flags, yes. It can call pagecache_get_page() instead of > > grab_cache_page_write_begin(). And then you don't need to change > > grab_cache_page_write_begin() at all. > > That would still require adding a new aop flag (AOP_FLAG_NOWAIT). > You are ok with that? No new AOP_FLAG. block_write_begin() does not get called with AOP_FLAG_NOWAIT in this series. You'd want to pass gfp flags to __block_write_begin_int instead of aop flags.