On Wed 28-01-09 12:19:15, Christoph Hellwig wrote: > On Tue, Jan 27, 2009 at 06:35:40PM +0100, Jan Kara wrote: > > On Tue 27-01-09 12:13:23, Christoph Hellwig wrote: > > > On Tue, Jan 27, 2009 at 05:48:38PM +0100, Jan Kara wrote: > > > > Use lowercase names of quota functions instead of old uppercase ones. > > > > > > Looking over this again I think the vfs_ names are a really bad choice. > > > The normal use for vfs_ are higher level functions that call into > > > specific filesystems, which these aren't really. What about just > > > striping out that vfs_ prefix first? > > Actually, these vfs_dq_ functions are usually just wrappers like: > > > > static inline void vfs_dq_init(struct inode *inode) > > { > > BUG_ON(!inode->i_sb); > > if (sb_any_quota_active(inode->i_sb) && !IS_NOQUOTA(inode)) > > inode->i_sb->dq_op->initialize(inode, -1); > > } > > > > where ->initialize either leads to a filesystem specified callback or to > > generic quota init function. So this seems to reasonably match your > > description above... > > But if this still has not convinced you ;), I can change all these quota > > functions to have names starting with dq_. That should not clash with > > anything else. But I'm not very enthusiastic about this change (cleanups are > > so boring...). > > Hmm, seems you're right - I must have been confused when looking at it. > > Changing away from the weird uppercase names defintively is a good > thing. > > Although for the ops inside the filesystem it might be better to just > call into the lowlevel operation instead of the vfs_ helper as we know > what we want, no? Yes, filesystem knows what it wants but the vfs_ helpers are there so that every filesystem does not have to implement the same checks (usually checking whether quota is enabled etc)... Honza -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html