On Fri, Oct 22, 2021 at 10:26:30PM +1100, NeilBrown wrote: > On Fri, 22 Oct 2021, Mel Gorman wrote: > > On Fri, Oct 22, 2021 at 12:15:10PM +1100, NeilBrown wrote: > > > > > In general, I still don't like the use of wake_up_all(), though it won't > > > cause incorrect behaviour. > > > > > > > Removing wake_up_all would be tricky. > > I think there is a misunderstanding. Removing wake_up_all() is as > simple as > s/wake_up_all/wake_up/ > > If you used prepare_to_wait_exclusive(), then wake_up() would only wake > one waiter, while wake_up_all() would wake all of them. > As you use prepare_to_wait(), wake_up() will wake all waiters - as will > wake_up_all(). > Ok, yes, there was a misunderstanding. I thought you were suggesting a move to exclusive wakeups. I felt that the wake_up_all was explicit in terms of intent and that I really meant for all tasks to wake instead of one at a time. -- Mel Gorman SUSE Labs