On 10/21/2021 4:28 AM, Christoph Hellwig wrote: >> + if (flags & DAXDEV_F_RECOVERY) { >> + lead_off = (unsigned long)addr & ~PAGE_MASK; >> + len = PFN_PHYS(PFN_UP(lead_off + bytes)); >> + if (is_bad_pmem(&pmem->bb, PFN_PHYS(pgoff) / 512, len)) { >> + if (lead_off || !(PAGE_ALIGNED(bytes))) { >> + dev_warn(dev, "Found poison, but addr(%p) and/or bytes(%#lx) not page aligned\n", >> + addr, bytes); >> + return (size_t) -EIO; >> + } >> + pmem_off = PFN_PHYS(pgoff) + pmem->data_offset; >> + if (pmem_clear_poison(pmem, pmem_off, bytes) != >> + BLK_STS_OK) >> + return (size_t) -EIO; >> + } > > Shouldn't this just go down in a separe ->clear_poison operation > to make the whole thing a little easier to follow? > Do you mean to lift or refactor the above to a helper function so as to improve the readability of the code? I can do that, just to confirm. On the same note, would you prefer to refactor the read path as well? thanks! -jane