On Sat, Sep 25, 2021 at 01:43:08PM +0200, Len Baker wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > In this case these are not actually dynamic sizes: all the operands > involved in the calculation are constant values. However it is better to > refactor them anyway, just to keep the open-coded math idiom out of > code. > > So, use the struct_size() helper to do the arithmetic instead of the > argument "size + count * size" in the kzalloc() functions. > > This code was detected with the help of Coccinelle and audited and fixed > manually. > > [1] https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > > Signed-off-by: Len Baker <len.baker@xxxxxxx> Reviewed-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx> Thanks -- Gustavo > --- > Changelog v1 -> v2 > - Rebase against v5.15-rc2 > - Refactor another instance in the same file (Gustavo A. R. Silva). > - Update the commit changelog to inform that this code was detected > using a Coccinelle script (Gustavo A. R. Silva). > > fs/fs-writeback.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/fs/fs-writeback.c b/fs/fs-writeback.c > index 81ec192ce067..5eb0ada7468c 100644 > --- a/fs/fs-writeback.c > +++ b/fs/fs-writeback.c > @@ -566,7 +566,7 @@ static void inode_switch_wbs(struct inode *inode, int new_wb_id) > if (atomic_read(&isw_nr_in_flight) > WB_FRN_MAX_IN_FLIGHT) > return; > > - isw = kzalloc(sizeof(*isw) + 2 * sizeof(struct inode *), GFP_ATOMIC); > + isw = kzalloc(struct_size(isw, inodes, 2), GFP_ATOMIC); > if (!isw) > return; > > @@ -624,8 +624,8 @@ bool cleanup_offline_cgwb(struct bdi_writeback *wb) > int nr; > bool restart = false; > > - isw = kzalloc(sizeof(*isw) + WB_MAX_INODES_PER_ISW * > - sizeof(struct inode *), GFP_KERNEL); > + isw = kzalloc(struct_size(isw, inodes, WB_MAX_INODES_PER_ISW), > + GFP_KERNEL); > if (!isw) > return restart; > > -- > 2.25.1 >