Linus Torvalds wrote: > > On Fri, 9 Jan 2009, Ingo Molnar wrote: >> >> -static inline int constant_test_bit(int nr, const volatile unsigned long *addr) >> +static __asm_inline int >> +constant_test_bit(int nr, const volatile unsigned long *addr) >> { >> return ((1UL << (nr % BITS_PER_LONG)) & >> (((unsigned long *)addr)[nr / BITS_PER_LONG])) != 0; > > Thios makes absolutely no sense. > > It's called "__always_inline", not __asm_inline. > > Why add a new nonsensical annotations like that? > __asm_inline was my suggestion, to distinguish "inline this unconditionally because gcc screws up in the presence of asm()" versus "inline this unconditionally because the world ends if it isn't" -- to tell the human reader, not gcc. I guess the above is a good indicator that the __asm_inline might have been a bad name. -hpa -- H. Peter Anvin, Intel Open Source Technology Center I work for Intel. I don't speak on their behalf. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html