On Tue, Jul 13, 2021 at 7:53 AM Christian Brauner <christian.brauner@xxxxxxxxxx> wrote: > > Instead of naming all these $something_helper I would follow the > underscore naming pattern we usually do, i.e. instead of e.g. > rmdir_helper do __rmdir() or __do_rmdir(). That's certainly a pattern we have, but I don't necessarily love it. It would be even better if we'd have names that actually explain what/why the abstraction exists. In this case, it's the "possibly retry due to ESTALE", but I have no idea how to sanely name that. Making it "try_rmdir()" or something like that is the best I can come up with right now. On a similar note, the existing "do_rmdir()" and friends aren't wonderful names either, but we expose that name out so changing it is probably not worth it. But right now we have "vfs_rmdir()" and "do_rmdir()", and they are just different levels of the "rmdir stack", without the name really describing where in the stack they are. Naming is hard, and I don't think the double underscores have been wonderful either. Linus