On Sat, Jul 03, 2021 at 11:05:07AM +0800, Zhang Yi wrote: > > Originally, I want to add this shrinker as a optional feature for jbd2 because > only ext4 use it now and I'm not sure does ocfs2 needs this feature. So I export > jbd2_journal_[un]register_shrinker(), ext4 could invoke them individually. The reason why bdev_try_to_free_page() callback was needed for ext4 --- namely so there was a way to release checkpointed buffers under memory pressure --- also exists for ocfs2. It was probably true that in most deployments of ocfs2, they weren't running with super-tight memory availability, so it may not have been necessary the same way that it might be necessary, say, if ext4 was being used on a Rasberry Pi. :-) > And one more thing we to could do is rename the 'j_jh_shrink_count' to something > like 'j_checkpoint_jh_count' because we always init it no matter we register the > shrinker or not later. That makes sense. In fact, unless I'm mistaken, I don't think it's legal to call percpu_counter_{inc,dec} if the shrinker isn't initialized. So for ocfs2, if we didn't initialize percpu_counter, when __jbd2_journal_insert_checkpoint() tries to call percpu_counter_inc(), I believe things would potentially go *boom* on some implementations of the percpu counter (e.g., on Power and ARM). So not only would it not hurt to register the shrinker for ocfs2, I think it's required. So yeah, let's rename it to something like j_checkpoint_jh_count, and then let's inline jbd2_journal_[un]register_shrinker() in journal_init_common() and jbd2_journal_unregister_shrinker(). What do you think? - Ted