On Wed, Jun 02, 2021 at 04:22:38PM -0700, Daniel Rosenberg wrote: > On Wed, Jun 2, 2021 at 12:54 PM Eric Biggers <ebiggers@xxxxxxxxxx> wrote: > > > > On Wed, Jun 02, 2021 at 04:15:39AM +0000, Daniel Rosenberg wrote: > > > +#ifdef CONFIG_UNICODE > > > +F2FS_FEATURE_RO_ATTR(encrypted_casefold, FEAT_ENCRYPTED_CASEFOLD); > > > +#endif > > > > Shouldn't it be defined(CONFIG_UNICODE) && defined(CONFIG_FS_ENCRYPTION)? > > > > > #endif > > > #ifdef CONFIG_BLK_DEV_ZONED > > > F2FS_FEATURE_RO_ATTR(block_zoned, FEAT_BLKZONED); > > > @@ -815,6 +823,9 @@ static struct attribute *f2fs_feat_attrs[] = { > > > #ifdef CONFIG_FS_ENCRYPTION > > > ATTR_LIST(encryption), > > > ATTR_LIST(test_dummy_encryption_v2), > > > +#ifdef CONFIG_UNICODE > > > + ATTR_LIST(encrypted_casefold), > > > +#endif > > > > Likewise here. > > > > - Eric > > Those are already within an #ifdef CONFIG_FS_ENCRYPTION, so it should > be covered already. Adding a comment to the #endif for CONFIG_FS_ENCRYPTION would make it easier to read: #endif /* CONFIG_FS_ENCRYPTION */ > Should I send a v2 set with the > > Fixes: 7ad08a58bf67 ("f2fs: Handle casefolding with Encryption") > Cc: stable@xxxxxxxxxxxxxxx # v5.11+ > > appended? Yes, please add those tags. - Eric