From: Wu Bo <wubo40@xxxxxxxxxx> Replace open coded divisor calculations with the DIV_ROUND_UP kernel macro for better readability. Signed-off-by: Wu Bo <wubo40@xxxxxxxxxx> --- fs/direct-io.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/fs/direct-io.c b/fs/direct-io.c index b2e86e7..6e7d402 100644 --- a/fs/direct-io.c +++ b/fs/direct-io.c @@ -195,7 +195,7 @@ static inline int dio_refill_pages(struct dio *dio, struct dio_submit *sdio) iov_iter_advance(sdio->iter, ret); ret += sdio->from; sdio->head = 0; - sdio->tail = (ret + PAGE_SIZE - 1) / PAGE_SIZE; + sdio->tail = DIV_ROUND_UP(ret, PAGE_SIZE); sdio->to = ((ret - 1) & (PAGE_SIZE - 1)) + 1; return 0; } -- 1.8.3.1