On Sat, May 22, 2021 at 07:31:55PM +0800, menglong8.dong@xxxxxxxxx wrote: > From: Menglong Dong <dong.menglong@xxxxxxxxxx> > > As for the existence of 'user root' which is introduced in previous > patch, 'rootfs_fs_type', which is used as the root of mount tree, > is not used directly any more. So it make no sense to switch it > between ramfs and tmpfs, just fix it with ramfs to simplify the > code. > diff --git a/init/do_mounts.c b/init/do_mounts.c > index 943cb58846fb..6d1253f75bb0 100644 > --- a/init/do_mounts.c > +++ b/init/do_mounts.c > @@ -689,24 +689,8 @@ void __init init_user_rootfs(void) > } > } > > -static bool is_tmpfs; > -static int rootfs_init_fs_context(struct fs_context *fc) > -{ > - if (IS_ENABLED(CONFIG_TMPFS) && is_tmpfs) > - return shmem_init_fs_context(fc); > - > - return ramfs_init_fs_context(fc); > -} > - > struct file_system_type rootfs_fs_type = { Then why not also just rename rootfs_fs_type to ram_rootfs_fs_type to make this even clearer now? > .name = "rootfs", > - .init_fs_context = rootfs_init_fs_context, > + .init_fs_context = ramfs_init_fs_context, > .kill_sb = kill_litter_super, > }; Luis