On Wed, Jan 20, 2021 at 10:17:04AM -0800, Darrick J. Wong wrote: > > @@ -598,11 +597,11 @@ EXPORT_SYMBOL_GPL(__iomap_dio_rw); > > ssize_t > > iomap_dio_rw(struct kiocb *iocb, struct iov_iter *iter, > > const struct iomap_ops *ops, const struct iomap_dio_ops *dops, > > - bool wait_for_completion) > > + unsigned int flags) > > Can this be named "dio_flags", since it's passed directly into > __iomap_dio_rw? > > > struct iomap_dio *__iomap_dio_rw(struct kiocb *iocb, struct iov_iter *iter, > > const struct iomap_ops *ops, const struct iomap_dio_ops *dops, > > - bool wait_for_completion); > > + unsigned int flags); > > ...and please make the naming of that last parameter consistent with the > definitions. :) Ok.