On Wed, Jan 13, 2021 at 1:52 AM Christian Brauner <christian.brauner@xxxxxxxxxx> wrote: > Add a simple helper to retrieve the user namespace associated with the > vfsmount of a file. Christoph correctly points out that this makes > codepaths (e.g. ioctls) way easier to follow that would otherwise > dereference via mnt_user_ns(file->f_path.mnt). > > In order to make file_user_ns() static inline we'd need to include > mount.h in either file.h or fs.h which seems undesirable so let's simply > not force file_user_ns() to be inline. [...] > +struct user_namespace *file_user_ns(struct file *file) > +{ > + return mnt_user_ns(file->f_path.mnt); > +} That name is confusing to me, because when I think of "the userns of a file", it's file->f_cred->user_ns. There are a bunch of places that look at that, as you can see from grepping for "f_cred->user_ns". If you really want this to be a separate helper, can you maybe give it a clearer name? file_mnt_user_ns(), or something like that, idk.