On Wed, Oct 28, 2020 at 02:04:08PM +0000, Christoph Hellwig wrote: > On Wed, Oct 28, 2020 at 07:32:00AM -0400, Brian Foster wrote: > > I used the variable just to avoid having to split the function call into > > multiple lines. I.e., it just looked more readable to me than: > > > > if (wpc->ops->discard_page) > > wpc->ops->discard_page(page, > > offset_in_page(file_offset)); > > > > I can change it back if that is preferred (or possibly use a function > > pointer variable instead). I suppose that's also avoided by passing > > file_offset directly, but that seems a little odd to me for a page > > oriented callback. > > I think passing the file offset makes more sense, especially as the > only instance needs it anyway. > The callback uses both, but I'm not tied to it either way. I'll make that tweak for the next version.. Brian