> > > + const struct path *path = fsnotify_data_path(data, data_type); > > > + struct mount *mnt = path ? real_mount(path->mnt) : NULL; > > > struct inode *inode = d_inode(dentry); > > > struct dentry *parent; > > > + bool parent_watched = dentry->d_flags & DCACHE_FSNOTIFY_PARENT_WATCHED; > > > + __u32 p_mask, test_mask, marks_mask = 0; > > > struct inode *p_inode; > > > int ret = 0; > > > > > > + /* > > > + * Do inode/sb/mount care about parent and name info on non-dir? > > > + * Do they care about any event at all? > > > + */ > > > + if (!inode->i_fsnotify_marks && !inode->i_sb->s_fsnotify_marks && > > > + (!mnt || !mnt->mnt_fsnotify_marks)) { > > > + if (!parent_watched) > > > + return 0; > > > + } else if (!(mask & FS_ISDIR) && !IS_ROOT(dentry)) { > > > + marks_mask |= fsnotify_want_parent(inode->i_fsnotify_mask); > > > + marks_mask |= fsnotify_want_parent(inode->i_sb->s_fsnotify_mask); > > > + if (mnt) > > > + marks_mask |= fsnotify_want_parent(mnt->mnt_fsnotify_mask); > > > + } > > > > OK, so AFAIU at this point (mask & marks_mask) tells us whether we need to > > grab parent because some mark needs parent into reported. Correct? > > > > Maybe I'd rename fsnotify_want_parent() (which seems like it returns bool) > > to fsnotify_parent_needed_mask() or something like that. Also I'd hide all > > those checks in a helper function like: > > > > fsnotify_event_needs_parent(mnt, inode, mask) > > > > So we'd then have just something like: > > if (!inode->i_fsnotify_marks && !inode->i_sb->s_fsnotify_marks && > > (!mnt || !mnt->mnt_fsnotify_marks) && !parent_watched) > > return 0; > > if (!parent_watched && !fsnotify_event_needs_parent(mnt, inode, mask)) > > goto notify_child; > > OK, but we'd still need to store marks_mask for later in case event > needs parent. > Nevermind, I understand now what you meant. Changed the function according to your guidance and looks much better. Fits now in one terminal screen :-) > > > ... > > > > > + > > > parent = NULL; > > > - if (!(dentry->d_flags & DCACHE_FSNOTIFY_PARENT_WATCHED)) > > > + test_mask = mask & FS_EVENTS_POSS_TO_PARENT; > > > + if (!(marks_mask & test_mask) && !parent_watched) > > > goto notify_child; > > > > > > + /* Does parent inode care about events on children? */ > > > parent = dget_parent(dentry); > > > p_inode = parent->d_inode; > > > + p_mask = fsnotify_inode_watches_children(p_inode); > > > > > > - if (unlikely(!fsnotify_inode_watches_children(p_inode))) { > > > + if (p_mask) > > > + marks_mask |= p_mask; > > > + else if (unlikely(parent_watched)) > > > __fsnotify_update_child_dentry_flags(p_inode); > > > - } else if (p_inode->i_fsnotify_mask & mask & ALL_FSNOTIFY_EVENTS) { > > > + > > > + if ((marks_mask & test_mask) && p_inode != inode) { > > ^^ this is effectively > > !IS_ROOT(dentry), isn't it? But since you've checked that above can it ever > > be that p_inode == inode? > > > > True, but only if you add the hidden assumption (which should be true) that > DCACHE_FSNOTIFY_PARENT_WATCHED cannot be set on an IS_ROOT > dentry. Otherwise you can have parent_watched and not check IS_ROOT() > so prefered defensive here, but I don't mind dropping it. > I dropped this and also dropped the IS_ROOT(dentry) check because there is already a check in the inline fsnotify_parent(). FYI, pushed these changes to branch fsnotify_name. Rebased/tested/pushed branch fanotify_name_fid on top. There are no changes to following patches as they are all fanotify patches. Thanks, Amir.