On Thu, Jul 9, 2020 at 8:18 AM Christoph Hellwig <hch@xxxxxx> wrote: > > There is no good reason to mess with file descriptors from in-kernel > code, switch the initramfs unpacking to struct file based write > instead. As we don't have nice helper for chmod or chown on a struct > file or struct path use the pathname based ones instead there. This > causes additional (cached) lookups, but keeps the code much simpler. This is the only one I'm not a huge fan of. I agree about moving to 'struct file'. But then you could just do the chown/chmod using chown/chmod_common() on file->f_path. That would keep the same semantics, and it feels like a more straightforward patch. It would still remove the nasty ksys_fchmod/fchmod, it would just require our - already existing - *_common() functions to be non-static (and maybe renamed to "vfs_chown/chmod()" instead, that "*_common()" naming looks a bit odd compared to all our other "vfs_operation()" helpers). Linus