On 7/8/20 4:40 PM, Matthew Wilcox wrote: > On Wed, Jul 08, 2020 at 04:37:21PM -0600, Jens Axboe wrote: >> On 7/8/20 4:26 PM, Matthew Wilcox (Oracle) wrote: >>> diff --git a/crypto/af_alg.c b/crypto/af_alg.c >>> index b1cd3535c525..590dbbcd0e9f 100644 >>> --- a/crypto/af_alg.c >>> +++ b/crypto/af_alg.c >>> @@ -1045,7 +1045,7 @@ void af_alg_async_cb(struct crypto_async_request *_req, int err) >>> af_alg_free_resources(areq); >>> sock_put(sk); >>> >>> - iocb->ki_complete(iocb, err ? err : (int)resultlen, 0); >>> + complete_kiocb(iocb, err ? err : (int)resultlen, 0); >> >> I'd prefer having it called kiocb_complete(), seems more in line with >> what you'd expect in terms of naming for an exported interface. > > Happy to make that change. It seemed like you preferred the opposite > way round with is_sync_kiocb() and init_sync_kiocb() already existing. > > Should I switch register_kiocb_completion and unregister_kiocb_completion > to kiocb_completion_register or kiocb_register_completion? I prefer the latter here, as per the other email. But as long as kiocb_ is the prefix, I don't really care that much. The latter is how you'd say it to, while the former sounds a bit yoda'ish. -- Jens Axboe