On Wed, Jun 24, 2020 at 11:11:50AM -0700, Linus Torvalds wrote: > What I mean was *not* something like uptr_t. > > Just keep the existing "set_fs()". It's not harmful if it's only used > occasionally. We should rename it once it's rare enough, though. > > Then, make the following changes: > > - all the normal user access functions stop caring. They use > TASK_SIZE_MAX and are done with it. They basically stop reacting to > set_fs(). > > - then, we can have a few *very* specific cases (like setsockopt, > maybe some random read/write) that we teach to use the new set_fs() > thing. > > So in *those* cases, we'd basically just do "oh, ok, we are supposed > to use a kernel pointer" based on the setfs value. > > IOW, I mean tto do something much more gradual. No new interfaces, no > new types, just a couple of (very clearly marked!) cases of the legacy > set_fs() behavior. So we'd need new user copy functions for just those cases, and make sure everything below the potential get_fs-NG uses them. But without any kind of tape safety to easily validate all users below actually use them? I just don't see how that makes sense. FYI, I think the only users where we really need it are setsockopt and a s390-specific driver from my audits so far. Everything else shouldn't need anything like that.