On Thu, May 21, 2020 at 05:04:11PM -0700, Matthew Wilcox wrote: > On Fri, May 22, 2020 at 08:49:06AM +1000, Dave Chinner wrote: > > Ok, so the main issue I have with the filesystem/iomap side of > > things is that it appears to be adding "transparent huge page" > > awareness to the filesysetm code, not "large page support". > > > > For people that aren't aware of the difference between the > > transparent huge and and a normal compound page (e.g. I have no idea > > what the difference is), this is likely to cause problems, > > especially as you haven't explained at all in this description why > > transparent huge pages are being used rather than bog standard > > compound pages. > > The primary reason to use a different name from compound_* > is so that it can be compiled out for systems that don't enable > CONFIG_TRANSPARENT_HUGEPAGE. So THPs are compound pages, as they always > have been, but for a filesystem, using thp_size() will compile to either > page_size() or PAGE_SIZE depending on CONFIG_TRANSPARENT_HUGEPAGE. Again, why is this dependent on THP? We can allocate compound pages without using THP, so why only allow the page cache to use larger pages when THP is configured? i.e. I don't know why this is dependent on THP because you haven't explained why this only works for THP and not just plain old compound pages.... > Now, maybe thp_size() is the wrong name, but then you need to suggest > a better name ;-) First you need to explain why THP is requirement for large pages in the page cache when most of the code changes I see only care if the page is a compound page or not.... Cheers, Dave. -- Dave Chinner david@xxxxxxxxxxxxx