On Sat, 2020-04-18 at 11:41 -0700, Randy Dunlap wrote: > Add the do_empty() macro to silence gcc warnings about an empty body > following an "if" statement when -Wextra is used. > > However, for debug printk calls that are being disabled, use either > no_printk() or pr_debug() [and optionally dynamic printk debugging] > instead. [] > +#define do_empty() do { } while (0) If this is really useful (I think the warning is somewhat silly) bikeshed: I think do_nothing() is more descriptive