Hello, Kernel core code is usually great and well designed IMHO. But here I find the page cache KPI really incosistent in its routine names. For example, here are different helpers I could find: page_cache_get() page_cache_release() page_cache_alloc() find_get_page() find_lock_page() grab_cache_page() grab_cache_page_nowait() read_cache_page_async() read_cache_page() add_to_page_cache() remove_from_page_cache() lock_page() wait_on_page_writeback() ... Do these inconsistencies exist for historical reasons or am I missing something ? If I am right, wouldn't it better for them to start with page_cache_ or something similar. Thanks -- Francis -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html