On Sun, Jan 19, 2020 at 03:17:13AM +0000, Al Viro wrote: > From: Al Viro <viro@xxxxxxxxxxxxxxxxxx> > > preparation to finish_automount() fix (next commit) > > Signed-off-by: Al Viro <viro@xxxxxxxxxxxxxxxxxx> Just a naming nit below. Acked-by: Christian Brauner <christian.brauner@xxxxxxxxxx> > --- > fs/namespace.c | 47 ++++++++++++++++++++++++----------------------- > 1 file changed, 24 insertions(+), 23 deletions(-) > > diff --git a/fs/namespace.c b/fs/namespace.c > index 2fd0c8bcb8c1..5f0a80f17651 100644 > --- a/fs/namespace.c > +++ b/fs/namespace.c > @@ -2697,45 +2697,32 @@ static int do_move_mount_old(struct path *path, const char *old_name) > /* > * add a mount into a namespace's mount tree > */ > -static int do_add_mount(struct mount *newmnt, struct path *path, int mnt_flags) > +static int do_add_mount(struct mount *newmnt, struct mountpoint *mp, > + struct path *path, int mnt_flags) Maybe this should now be named do_add_mount_locked() so callers know that they need to do locking themselves? But that's bikeshedding... Christian