… > +++ b/fs/exfat/fatent.c … > +int exfat_zeroed_cluster(struct inode *dir, unsigned int clu) > +{ … > +error: > + exfat_msg(sb, KERN_ERR, "failed zeroed sect %llu\n", > + (unsigned long long)blknr); … Can the label “report_failure” be more helpful? … > +int exfat_alloc_cluster(struct inode *inode, unsigned int num_alloc, > + struct exfat_chain *p_chain) > +{ … > +error: > + if (num_clusters) > + exfat_free_cluster(inode, p_chain); Can a label like “check_num_clusters” be nicer? Regards, Markus