… > +++ b/fs/exfat/inode.c … > +static int exfat_create(struct inode *dir, struct dentry *dentry, umode_t mode, > + bool excl) > +{ … +out: + mutex_unlock(&EXFAT_SB(sb)->s_lock); Can the label “unlock” be more appropriate? > +static struct dentry *exfat_lookup(struct inode *dir, struct dentry *dentry, > + unsigned int flags) > +{ … > +error: > + mutex_unlock(&EXFAT_SB(sb)->s_lock); Would you like to use the label “unlock” also at this place (and similar ones)? > +static int exfat_search_empty_slot(struct super_block *sb, > + struct exfat_hint_femp *hint_femp, struct exfat_chain *p_dir, > + int num_entries) > +{ … > +out: > + kfree(clu); How do you think about to rename the label to “free_clu”? Regards, Markus