Re: KCSAN: data-race in __alloc_file / __alloc_file

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Nov 12, 2019 at 02:07:03PM -0800, Eric Dumazet wrote:
> 
> I would prefer some kind of explicit marking, instead of a comment.
> 
> Even if we prefer having a sane compiler, having these clearly
> annotated can help
> code readability quite a lot.

Annotating every line where tsk->min_flt is used with a comment
or explicit macro seems like a lot of churn.
How about adding an attribute to a field ?
Or an attribute to a type?

clang attributes can be easily exteneded. We add bpf specific attributes
that are known to clang only when 'clang -target bpf' is used.
There could be x86 or generic attributes.
Then one can do:
typedef unsigned long __attribute__((ignore_data_race)) racy_u64;
struct task_struct { 
   racy_u64 min_flt;
};

Hopefully less churn and clear signal to clang.




[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [Samba]     [Device Mapper]     [CEPH Development]

  Powered by Linux