On Wed, Oct 02, 2019 at 09:32:11PM +0800, Hillf Danton wrote: > > On Tue, 24 Sep 2019 17:52:02 -0700 From: Matthew Wilcox (Oracle) > > > > @@ -1415,6 +1415,8 @@ static inline void clear_page_pfmemalloc(struct page *page) > > extern void pagefault_out_of_memory(void); > > > > #define offset_in_page(p) ((unsigned long)(p) & ~PAGE_MASK) > > With the above define, the page_offset function is not named as badly > as 03/15 claims. Just because there exists a function that does the job, does not mean that the other function is correctly named. > > +#define offset_in_this_page(page, p) \ > > + ((unsigned long)(p) & (page_size(page) - 1)) > > What if Ted will post a rfc with offset_in_that_page defined next week? Are you trying to be funny?