On Mon, Jun 24, 2019 at 08:51:37AM -0700, Matthew Wilcox wrote: > The usual convention in list.h is that list_foo uses the list head and > list_foo_entry uses the container type. So I think this should be > renamed to list_pop_entry() at least. Do we also want: > > static inline struct list_head *list_pop(struct list_head *head) > { > struct list_head *first = READ_ONCE(head->next); > > if (first == head) > return NULL; > __list_del(head, first->next); > return first; > } > > we also seem to prefer using inline functions over #defines in this > header file. Sure, I can rename it and split the implementation.