On Tue, 2019-06-25 at 13:17 +1000, Alastair D'Silva wrote: > From: Alastair D'Silva <alastair@xxxxxxxxxxx> > > In order to support additional features, rename hex_dump_to_buffer to > hex_dump_to_buffer_ext, and replace the ascii bool parameter with flags. [] > diff --git a/drivers/gpu/drm/i915/intel_engine_cs.c b/drivers/gpu/drm/i915/intel_engine_cs.c [] > @@ -1338,9 +1338,8 @@ static void hexdump(struct drm_printer *m, const void *buf, size_t len) > } > > WARN_ON_ONCE(hex_dump_to_buffer(buf + pos, len - pos, > - rowsize, sizeof(u32), > - line, sizeof(line), > - false) >= sizeof(line)); > + rowsize, sizeof(u32), line, > + sizeof(line)) >= sizeof(line)); Huh? Why do this? > diff --git a/drivers/isdn/hardware/mISDN/mISDNisar.c b/drivers/isdn/hardware/mISDN/mISDNisar.c [] > @@ -70,8 +70,9 @@ send_mbox(struct isar_hw *isar, u8 his, u8 creg, u8 len, u8 *msg) > int l = 0; > > while (l < (int)len) { > - hex_dump_to_buffer(msg + l, len - l, 32, 1, > - isar->log, 256, 1); > + hex_dump_to_buffer_ext(msg + l, len - l, 32, 1, > + isar->log, 256, > + HEXDUMP_ASCII); Again, why do any of these? The point of the wrapper is to avoid changing these.