On Mon, Apr 21, 2008 at 04:59:47AM -0400, Christoph Hellwig wrote: > > +STATIC struct dentry * > > +xfs_ci_dentry_update( > > + struct dentry *dent, > > + struct inode *dent_inode, > > + struct xfs_name *name) > > +{ > > + int err; > > + struct dentry *real_dent; > > + struct dentry *new_dent; > > + struct qstr nls_name; > > This helper should go into fs/dcache.c with a slightly move descritive > name (d_add_ci?). > > Also the naming is rather odd, please replace every occurance of > dent with dentry, and the variable dent_inode should be just inode. > > Also when moving this to dcache.c please provide a nice big kerneldoc > comment describing it like Anton did for the ntfs lookup instance. Perhaps this can be done (moving to dcache.c) as a followup patch series that also removes the duplicate code from ntfs and other places. Similarly for all the NLS stuff... Cheers, Dave. -- Dave Chinner Principal Engineer SGI Australian Software Group -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html