> > > > +/* Events types that may be reported from vfs */ > > > > +#define FANOTIFY_EVENT_TYPES (FANOTIFY_EVENTS | \ > > > > + FANOTIFY_PERM_EVENTS) > > > > + > > > > /* Extra flags that may be reported with event or control handling of events */ > > > > #define FANOTIFY_EVENT_FLAGS (FAN_EVENT_ON_CHILD | FAN_ONDIR) > > > > > > > > /* Events that may be reported to user */ > > > > -#define FANOTIFY_OUTGOING_EVENTS (FANOTIFY_EVENTS | \ > > > > - FANOTIFY_PERM_EVENTS | \ > > > > - FAN_Q_OVERFLOW) > > > > +#define FANOTIFY_OUTGOING_EVENTS (FANOTIFY_EVENT_TYPES | \ > > > > + FAN_Q_OVERFLOW | FAN_ONDIR) > > > > > > > > #define ALL_FANOTIFY_EVENT_BITS (FANOTIFY_OUTGOING_EVENTS | \ > > > > FANOTIFY_EVENT_FLAGS) > > > > > > I don't like this renaming. FAN_ONDIR essentially becomes the same type of > > > thing as FAN_EVENT_ON_CHILD - i.e., an event flag. So I'd just leave these > > > defines as is... > > > > > > > Sorry. I don't understand what you mean. > > FAN_EVENT_ON_CHILD is not in FANOTIFY_OUTGOING_EVENTS > > FAN_ONDIR is in FANOTIFY_OUTGOING_EVENTS after this change. > > copy_event_to_user() masks out with FANOTIFY_OUTGOING_EVENTS. > > Do you not like the new group definition FANOTIFY_EVENT_TYPES? > > Sorry, I've got confused and thought that FAN_EVENT_ON_CHILD gets reported > to userspace. I don't like the FANOTIFY_EVENT_TYPES name and > FANOTIFY_OUTGOING_EVENTS becomes somewhat a misnomer after adding FAN_ONDIR > there. So how about renaming FANOTIFY_OUTGOING_EVENTS to > FANOTIFY_OUTGOING_MASK and have FANOTIFY_OUTGOING_EVENTS what your > FANOTIFY_EVENT_TYPES is? > Jan, I decided to avert this specific bikeshed and my updated version does not use any new defined. Thanks, Amir.