On Tue, Dec 04, 2018 at 05:18:32PM -0800, anthony.yznaga@xxxxxxxxxx wrote: > On 12/04/2018 04:48 PM, Matthew Wilcox wrote: > > On Tue, Dec 04, 2018 at 02:45:26PM -0800, Anthony Yznaga wrote: > >> +static inline int page_has_type(struct page *page) > >> +{ > >> + return (PageType(page, 0) && > >> + ((page->page_type & PAGE_TYPE_ALL) != PAGE_TYPE_ALL)); > >> +} > >> + > > > > I think this is a bit complex, and a bit of a pain to update as we add > > new page types. How about this? > > > > return (int)page_type < -128; > > > > (I'm open to appropriate #defines to make this more obvious that it's ~0x7F) > > I thought about having this: > > #define PAGE_TYPE_END 0xffffff80 > > static int inline page_has_type(struct page *page) > { > return page->page_type > PAGE_TYPE_BASE && > page->page_type < PAGE_TYPE_END; > } > > But I opted for the additional complexity to avoid more false-positives from > possibly corrupted values. I'm certainly fine with a simple approach, though. The way I'm thinking about this field is that usually it's _mapcount which is 0xffffffff to represent 0. We allow a certain small amount of underflow and still treat it as a mapcount. We also allow for some amount of overflow. So to be utterly precise, what you had there would have been fine, but for simplicity, I'd rather just do a signed compare against -128.