On Fri, Oct 12, 2018 at 12:22:26PM +1100, Dave Chinner wrote: > On Wed, Oct 10, 2018 at 09:15:19PM -0700, Darrick J. Wong wrote: > > From: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > > > > Back when the XFS reflink code only supported clone_file_range, we were > > only able to return zero or negative error codes to userspace. However, > > now that copy_file_range (which returns bytes copied) can use XFS' > > clone_file_range, we have the opportunity to return partial results. > > For example, if userspace sends a 1GB clone request and we run out of > > space halfway through, we at least can tell userspace that we completed > > 512M of that request like a regular write. > > > > Signed-off-by: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > > --- > > fs/xfs/xfs_file.c | 5 +---- > > fs/xfs/xfs_reflink.c | 19 ++++++++++++++----- > > fs/xfs/xfs_reflink.h | 2 +- > > 3 files changed, 16 insertions(+), 10 deletions(-) > > > > > > diff --git a/fs/xfs/xfs_file.c b/fs/xfs/xfs_file.c > > index bc9e94bcb7a3..b2b15b8dc4a1 100644 > > --- a/fs/xfs/xfs_file.c > > +++ b/fs/xfs/xfs_file.c > > @@ -928,14 +928,11 @@ xfs_file_remap_range( > > loff_t len, > > unsigned int remap_flags) > > { > > - int ret; > > - > > if (!remap_check_flags(remap_flags, RFR_SAME_DATA)) > > return -EINVAL; > > > > - ret = xfs_reflink_remap_range(file_in, pos_in, file_out, pos_out, > > + return xfs_reflink_remap_range(file_in, pos_in, file_out, pos_out, > > len, remap_flags); > > - return ret < 0 ? ret : len; > > } > > > > STATIC int > > diff --git a/fs/xfs/xfs_reflink.c b/fs/xfs/xfs_reflink.c > > index e1592e751cc2..12a1fe92454e 100644 > > --- a/fs/xfs/xfs_reflink.c > > +++ b/fs/xfs/xfs_reflink.c > > @@ -1123,6 +1123,7 @@ xfs_reflink_remap_blocks( > > struct xfs_inode *dest, > > xfs_fileoff_t destoff, > > xfs_filblks_t len, > > + xfs_filblks_t *remapped, > > xfs_off_t new_isize) > > { > > struct xfs_bmbt_irec imap; > > @@ -1130,6 +1131,7 @@ xfs_reflink_remap_blocks( > > int error = 0; > > xfs_filblks_t range_len; > > > > + *remapped = 0; > > /* drange = (destoff, destoff + len); srange = (srcoff, srcoff + len) */ > > while (len) { > > uint lock_mode; > > @@ -1168,6 +1170,7 @@ xfs_reflink_remap_blocks( > > srcoff += range_len; > > destoff += range_len; > > len -= range_len; > > + *remapped += range_len; > > } > > So "remapped" is a block count? Can we call this something like > remap_len so it's obvious what it is tracking? Ok. > > @@ -1424,11 +1427,17 @@ xfs_reflink_remap_range( > > > > trace_xfs_reflink_remap_range(src, pos_in, len, dest, pos_out); > > > > + if (len == 0) { > > + ret = 0; > > + goto out_unlock; > > + } > > + > > dfsbno = XFS_B_TO_FSBT(mp, pos_out); > > sfsbno = XFS_B_TO_FSBT(mp, pos_in); > > fsblen = XFS_B_TO_FSB(mp, len); > > ret = xfs_reflink_remap_blocks(src, sfsbno, dest, dfsbno, fsblen, > > - pos_out + len); > > + &remapped, pos_out + len); > > + remapped = min_t(int64_t, len, XFS_FSB_TO_B(mp, remapped)); > > So remapped is returned as a block count, then immediately converted > to a byte count? Can we return it as byte count so that we don't > have this weird unit conversion? But then we'd have a function whose inputs are in units of blocks but whose return value is in units of bytes. Maybe I'll just do this to make it more explicit: xfs_filblks_t remapped_blocks = 0; loff_t remapped_bytes = 0; ret = xfs_reflink_remap_blocks(..., &remapped_blocks...); remapped_bytes = min_t(int64_t, len, XFS_FSB_TO_B(mp, remapped_blocks)); ... return remapped_bytes > 0 ? remapped_bytes : ret; --D > Cheers, > > Dave. > -- > Dave Chinner > david@xxxxxxxxxxxxx