> > -int rotate_reclaimable_page(struct page *page) > > +void rotate_reclaimable_page(struct page *page) > > { > > - struct pagevec *pvec; > > - unsigned long flags; > > - > > - if (PageLocked(page)) > > - return 1; > > - if (PageDirty(page)) > > - return 1; > > - if (PageActive(page)) > > - return 1; > > - if (!PageLRU(page)) > > - return 1; > > Might be me, but I find the above easier to read than > > > + if (!PageLocked(page) && !PageDirty(page) && !PageActive(page) && > > + PageLRU(page)) { > > Matter of taste, returning from a middle of a function is generally to be avoided (unless not). Anyway, this is just a side effect of the main cleanup, so I think I'm entitled to choose the style I prefer ;) Miklos -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html