On Mon, Jun 18, 2018 at 01:02:54PM +0100, Mark Rutland wrote: > Currently we have a couple of helpers to manipulate bits in particular > sysregs: > > * config_sctlr_el1(u32 clear, u32 set) > > * change_cpacr(u64 val, u64 mask) > > The parameters of these differ in naming convention, order, and size, > which is unfortunate. They also differ slightly in behaviour, as > change_cpacr() skips the sysreg write if the bits are unchanged, which > is a useful optimization when sysreg writes are expensive. > > Before we gain more yet another sysreg manipulation function, let's > unify these with a common helper, providing a consistent order for > clear/set operands, and the write skipping behaviour from > change_cpacr(). Code will be migrated to the new helper in subsequent > patches. > > Signed-off-by: Mark Rutland <mark.rutland@xxxxxxx> > Reviewed-by: Dave Martin <dave.martin@xxxxxxx> > Cc: Catalin Marinas <catalin.marinas@xxxxxxx> > Cc: Marc Zyngier <marc.zyngier@xxxxxxx> Acked-by: Catalin Marinas <catalin.marinas@xxxxxxx>