Re: [PATCH] fs/fcntl: restore checking against COMPAT_LOFF_T_MAX for F_GETLK64

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 2017-11-14 at 04:30 +0300, Vitaly Lipatov wrote:
> for fcntl64 with F_GETLK64 we need use checking against COMPAT_LOFF_T_MAX.
> 
> Fixes: 94073ad77fff2 "fs/locks: don't mess with the address limit in compat_fcntl64"
> 
> Signed-off-by: Vitaly Lipatov <lav@xxxxxxxxxxx>
> ---
>  fs/fcntl.c | 21 ++++++++++++++++++++-
>  1 file changed, 20 insertions(+), 1 deletion(-)
> 
> diff --git a/fs/fcntl.c b/fs/fcntl.c
> index 30f47d0..fa17f67 100644
> --- a/fs/fcntl.c
> +++ b/fs/fcntl.c
> @@ -604,6 +604,25 @@ static int fixup_compat_flock(struct flock *flock)
>  	return 0;
>  }
>  
> +/*
> + * GETLK64 was successful and we need to return the data, but it needs to fit in
> + * the compat structure.
> + * l_start shouldn't be too big, unless the original start + end is greater than
> + * COMPAT_LOFF_T_MAX, in which case the app was asking for trouble, so we return
> + * -EOVERFLOW in that case.  l_len could be too big, in which case we just
> + * truncate it, and only allow the app to see that part of the conflicting lock
> + * that might make sense to it anyway
> + */
> +
> +static int fixup_compat_l_flock(struct flock *flock)
> +{
> +	if (flock->l_start > COMPAT_LOFF_T_MAX)
> +		return -EOVERFLOW;
> +	if (flock->l_len > COMPAT_LOFF_T_MAX)
> +		flock->l_len = COMPAT_LOFF_T_MAX;
> +	return 0;
> +}
> +

(cc'ing Christoph since he wrote the original patch)

This patch looks correct to me, but could we rename it to
fixup_compat_flock64 to match the other functions here?

Also, I think this should probably go to stable -- any objections?

>  COMPAT_SYSCALL_DEFINE3(fcntl64, unsigned int, fd, unsigned int, cmd,
>  		       compat_ulong_t, arg)
>  {
> @@ -644,7 +663,7 @@ COMPAT_SYSCALL_DEFINE3(fcntl64, unsigned int, fd, unsigned int, cmd,
>  		err = fcntl_getlk(f.file, convert_fcntl_cmd(cmd), &flock);
>  		if (err)
>  			break;
> -		err = fixup_compat_flock(&flock);
> +		err = fixup_compat_l_flock(&flock);
>  		if (err)
>  			return err;
>  		err = put_compat_flock64(&flock, compat_ptr(arg));


-- 
Jeff Layton <jlayton@xxxxxxxxxx>



[Index of Archives]     [Linux Ext4 Filesystem]     [Union Filesystem]     [Filesystem Testing]     [Ceph Users]     [Ecryptfs]     [AutoFS]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux Cachefs]     [Reiser Filesystem]     [Linux RAID]     [Samba]     [Device Mapper]     [CEPH Development]
  Powered by Linux