* Dan Williams <dan.j.williams@xxxxxxxxx> wrote: > +#ifdef CONFIG_ARCH_HAS_UACCESS_WRITETHRU > +#define __HAVE_ARCH_MEMCPY_WRITETHRU 1 > +void memcpy_writethru(void *dst, const void *src, size_t cnt); > +#endif This should be named memcpy_wt(), which is the well-known postfix for write-through. We already have ioremap_wt(), set_memory_wt(), etc. - no need to introduce a longer variant with uncommon spelling. Thanks, Ingo