On Thu, Dec 22, 2016 at 11:15 AM, Jan Kara <jack@xxxxxxx> wrote: > Inline these helpers as they are very thin. We still keep them as we > don't want to expose details about how list type is determined. > > Signed-off-by: Jan Kara <jack@xxxxxxx> This patch looks good, but see comment below about suggested extra cleanup. Reviewed-by: Amir Goldstein <amir73il@xxxxxxxxx> > +/* run all the marks in a group, and clear all of the vfsmount marks */ > +static inline void fsnotify_clear_vfsmount_marks_by_group(struct fsnotify_group *group) > +{ > + fsnotify_clear_marks_by_group_flags(group, FSNOTIFY_LIST_TYPE_VFSMOUNT); Suggestion for extra cleanup while at it: IMO, the choice of name fsnotify_clear_marks_by_group_flags() was a bad choice, because 1. it sounds like "by group->flags" and its not 2. it is presented as a generic helper, but it is never likely to be used by anything other then those 2 call sites for FAN_MARK_FLUSH api So given the above, I think it would make more sense to name the function fsnotify_clear_marks_by_group_and_type() for what it really is. -- To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html