On Tue, Aug 28, 2007 at 09:49:38PM +0200, J??rn Engel wrote: > On Tue, 28 August 2007 12:05:58 -0700, clameter@xxxxxxx wrote: > > > > - index = *ppos >> PAGE_CACHE_SHIFT; > > - offset = *ppos & ~PAGE_CACHE_MASK; > > + index = page_cache_index(mapping, *ppos); > > + offset = page_cache_offset(mapping, *ppos); > > Part of me feels inclined to marge this patch now because it makes the > code more readable, even if page_cache_index() is implemented as > #define page_cache_index(mapping, pos) ((pos) >> PAGE_CACHE_SHIFT) > > I know there is little use in yet another global search'n'replace > wankfest and Andrew might wash my mouth just for mentioning it. Still, > hard to dislike this part of your patch. Yes, I I suggested that before. Andrew seems to somehow hate this patchset, but even if we don;'t get it in the lowercase macros are much much better then the current PAGE_CACHE_* confusion. - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html