On Sat, Jun 30, 2007 at 10:22:43AM +0100, Christoph Hellwig wrote: > On Fri, Jun 29, 2007 at 03:21:27PM -0400, J. Bruce Fields wrote: > > From: J. Bruce Fields <bfields@xxxxxxxxxxxxxx> > > > > We've been using the convention that vfs_foo is the function that calls > > a filesystem-specific foo method if it exists, or falls back on a > > generic method if it doesn't. > > > > So rename setlease to vfs_setlease, and __setlease to setlease. Keep > > setlease exported to allow filesystems to use the generic method in > > addition to doing their own bookkeeping. > > This should be moved before patch 2 and can probably go in once 2.6.23 > opens aswell. > > > @@ -1339,7 +1339,7 @@ int fcntl_getlease(struct file *filp) > > * > > * Called with kernel lock held. > > */ > > -static int __setlease(struct file *filp, long arg, struct file_lock **flp) > > +int setlease(struct file *filp, long arg, struct file_lock **flp) > > Except this shouldn't be made non-static in this patch. > > > extern int setlease(struct file *, long, struct file_lock **); > > And this prototype shouldn't be kept. If you want to use it somewhere > later in the patch series make it non-static and export it in a separate > patch. If it's ever intended to be export it should probably get a > better name aswell, e.g. generic_setlease. OK, done.--b. - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html