On Thu, Feb 08, 2007 at 06:03:50PM -0800, Nate Diller wrote: > On 2/8/07, Nick Piggin <npiggin@xxxxxxx> wrote: > >On Thu, Feb 08, 2007 at 07:49:53PM +0000, Christoph Hellwig wrote: > >> On Thu, Feb 08, 2007 at 02:07:24PM +0100, Nick Piggin wrote: > >> > Add an iterator data structure to operate over an iovec. Add usercopy > >> > operators needed by generic_file_buffered_write, and convert that > >function > >> > over. > >> > >> iovec_iterator is an awfully long and not very descriptive name. > >> In past discussions we named this thingy iodesc and wanted to pass it > >> down all the I/O path, including the file operations. > > > >Hi Christoph, > > > >Sure I think it would be a good idea to shorten the name. And yes, although > >I just construct the iterator to pass into perform_write, I think it should > >make sense to go much further up the call stack instead of passing all > >those > >args around. iodesc seems like a fine name, so I'll use that unless > >anyone objects. > > i had a patch integrating the iodesc idea, but after some thought, had > decided to call it struct file_io. That name reflects the fact that > it's doing I/O in arbitrary lengths with byte offsets, and struct > file_io *fio contrasts well with struct bio (block_io). I also had > used the field ->nbytes instead of ->count, to clarify the difference > between segment iterators, segment offsets, and absolute bytecount. The field name is a good suggestion. What I have there is not actually a full-blown file io descriptor, because there is no file or offset. It is just an iovec iterator (so maybe I should rename it to iov_iter, rather than iodesc). I think it might be a nice idea to keep this iov_iter as a standalone structure, and it could be embedded into a struct file_io? Thanks, Nick - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html