==> Regarding [RFC 0/5] dio: clean up completion phase of direct_io_worker(); Zach Brown <zach.brown@xxxxxxxxxx> adds: zach.brown> There have been a lot of bugs recently due to the way zach.brown> direct_io_worker() tries to decide how to finish direct IO zach.brown> operations. In the worst examples it has failed to call zach.brown> aio_complete() at all (hang) or called it too many times zach.brown> (oops). zach.brown> This set of patches cleans up the completion phase with the zach.brown> goal of removing the complexity that lead to these bugs. We zach.brown> end up with one path that calculates the result of the zach.brown> operation after all off the bios have completed. We decide zach.brown> when to generate a result of the operation using that path zach.brown> based on the final release of a refcount on the dio structure. [...] zach.brown> I hoped to get some feedback (and maybe volunteers for zach.brown> testing!) by sending the patches out before waiting for the zach.brown> stress tests. This all looks good, the code is much easier to follow. What do you think about making dio->result an unsigned quantity? It should never be negative now that there is an io_error field. ACK. Jeff - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html