I think I'll just slam all this in at the first opportunity. Stuff will break, but it will be easy to fix. If you try to upissue this patchset I shall be seeking an IP-routable hand grenade. On Tue, 29 Aug 2006 19:06:34 +0100 David Howells <dhowells@xxxxxxxxxx> wrote: > +static inline long blk_congestion_wait(int rw, long timeout) > +{ > + return timeout; > +} This function is misnamed and is implemented in the wrong place. It's not really a block thing at all. If/when/soon NFS starts to implement it and call it, things will need to be renamed and reshuffled. Simply stubbing it out like this will cause general mayhem and CPU meltdown all over the writeback and page-reclaim code. So... for now, I'll replace it with a simple io_schedule_timeout(timeout), which is equivalent to what we do now for network filesystems. - To unsubscribe from this list: send the line "unsubscribe linux-fsdevel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html