On 2023-06-19 at 15:56:34 -0400, Peter Colberg wrote: > Replace all shifts by PAGE_SHIFT with PFN_DOWN() and PFN_PHYS() helper > macros to convert between physical addresses and page frame numbers. > > These changes are cosmetic only; no functional changes. > > Suggested-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > Signed-off-by: Peter Colberg <peter.colberg@xxxxxxxxx> > Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > --- > v2: > - Comment in commit message that changes are cosmetic only > --- > drivers/fpga/dfl-afu-dma-region.c | 7 ++++--- > drivers/fpga/dfl-afu-main.c | 5 +++-- > 2 files changed, 7 insertions(+), 5 deletions(-) > > diff --git a/drivers/fpga/dfl-afu-dma-region.c b/drivers/fpga/dfl-afu-dma-region.c > index 02b60fde0430..e8d54cfbb301 100644 > --- a/drivers/fpga/dfl-afu-dma-region.c > +++ b/drivers/fpga/dfl-afu-dma-region.c > @@ -10,6 +10,7 @@ > */ > > #include <linux/dma-mapping.h> > +#include <linux/pfn.h> > #include <linux/sched/signal.h> > #include <linux/uaccess.h> > #include <linux/mm.h> > @@ -34,7 +35,7 @@ void afu_dma_region_init(struct dfl_feature_platform_data *pdata) > static int afu_dma_pin_pages(struct dfl_feature_platform_data *pdata, > struct dfl_afu_dma_region *region) > { > - int npages = region->length >> PAGE_SHIFT; > + int npages = PFN_DOWN(region->length); I don't much prefer this change, it is not doing the phy addr to pfn convertion. The macro name doesn't match what is doing here. > struct device *dev = &pdata->dev->dev; > int ret, pinned; > > @@ -82,7 +83,7 @@ static int afu_dma_pin_pages(struct dfl_feature_platform_data *pdata, > static void afu_dma_unpin_pages(struct dfl_feature_platform_data *pdata, > struct dfl_afu_dma_region *region) > { > - long npages = region->length >> PAGE_SHIFT; > + long npages = PFN_DOWN(region->length); ditto > struct device *dev = &pdata->dev->dev; > > unpin_user_pages(region->pages, npages); > @@ -101,7 +102,7 @@ static void afu_dma_unpin_pages(struct dfl_feature_platform_data *pdata, > */ > static bool afu_dma_check_continuous_pages(struct dfl_afu_dma_region *region) > { > - int npages = region->length >> PAGE_SHIFT; > + int npages = PFN_DOWN(region->length); ditto > int i; > > for (i = 0; i < npages - 1; i++) > diff --git a/drivers/fpga/dfl-afu-main.c b/drivers/fpga/dfl-afu-main.c > index 7f621e96d3b8..048c9b418c8b 100644 > --- a/drivers/fpga/dfl-afu-main.c > +++ b/drivers/fpga/dfl-afu-main.c > @@ -16,6 +16,7 @@ > > #include <linux/kernel.h> > #include <linux/module.h> > +#include <linux/pfn.h> > #include <linux/uaccess.h> > #include <linux/fpga-dfl.h> > > @@ -816,7 +817,7 @@ static int afu_mmap(struct file *filp, struct vm_area_struct *vma) > > pdata = dev_get_platdata(&pdev->dev); > > - offset = vma->vm_pgoff << PAGE_SHIFT; > + offset = PFN_PHYS(vma->vm_pgoff); ditto. The variables are offsets within file, not phys addr & pfn. > ret = afu_mmio_region_get_by_offset(pdata, offset, size, ®ion); > if (ret) > return ret; > @@ -837,7 +838,7 @@ static int afu_mmap(struct file *filp, struct vm_area_struct *vma) > vma->vm_page_prot = pgprot_noncached(vma->vm_page_prot); > > return remap_pfn_range(vma, vma->vm_start, > - (region.phys + (offset - region.offset)) >> PAGE_SHIFT, > + PFN_DOWN(region.phys + (offset - region.offset)), > size, vma->vm_page_prot); > } > > -- > 2.28.0 >